vTESTstudio 5.0.192 SP3

Minimum required CANoe/CANoe4SW version for the usage of full functional range in vTESTstudio 5.0 SP3:
CANoe/CANoe4SW 14

Minimum required CANoe version for the usage of limited feature set in vTESTstudio 5.0 SP3:  
CANoe 11.0 SP3, 12.0, 13.0

More details about vTESTstudio/CANoe version compatibility can be found on our website.

With vTESTstudio Service Pack 3, the following changes become effective:

General:

  • DO (Distributed Objects) data members of type Int and Float are supported in test commands and background checks within the Test Table Editor and Diagram Editors
  • TestUnitBuidCLI: New Add-On (www.vector.com/vteststudio-addons/) provides the possibility to automatically build test units per command line, e.g. for the usage in continuous integration environments

CAPL:

  • CAPL files can now be encrypted and integrated as encrypted sources into the vTESTstudio project, this enables whole test projects to be shared without publishing the CAPL code
  • New CAPL event ‚on testContextCompleted’ provides the possibility to transfer code coverage data after the execution of test tree elements of type test case and test sequence

Traceability:

  • The ReqIF import of trace items now supports values of type enumeration

Test Sequence Diagram Editor:

  • The limit of 64 variables per diagram (including all linked diagrams) was repealed

Together with CANoe/CANoe4SW 14:

  • Verdict ‘Inconclusive’ now available as criteria for test stop in test configuration dialog

Compatibility hint (!):

  • Test units that contain test sequence diagrams with variables cannot be executed with a CANoe version < 12.0 any longer.

 

용량 : 711.19 MB
MD5 Hash : 7c07454a5bf20d745ce506a2058699de
다운로드 이전 페이지